myHR Learn (Human Resources Systems) Service Interruption

Resolved

Northwestern Information Technology confirms that the incident has been resolved.
Posted Jun 20, 2025 - 20:25 CDT

Investigating

Northwestern Information Technology is investigating an issue causing myHR Learn (Human Resources Systems) to be inaccessible. The vendor has been engaged for this issue. Support staff are working to restore service as soon as possible.

The next update will be provided by 21:00 CDT.
Posted Jun 20, 2025 - 19:54 CDT
This incident affected: Administrative and Business (myHR Learn (Human Resources Systems)).