Northwestern Information Technology is monitoring the recovery of wired, wireless, and telephone services for the first floor E wing of the Technological Institute. Support staff will continue to closely monitor these services to ensure they are stable.
The next update will be provided by 15:30 CST.
Posted Feb 20, 2026 - 14:56 CST
Investigating
Northwestern Information Technology is investigating an issue causing a service interruption to the wired, wireless, and telephone services on the first floor E wing of the Technological Institute. Support staff are working to restore service as quickly as possible.
The next update will be provided by 15:00 CST.
Posted Feb 20, 2026 - 14:20 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).