Northwestern Online Giving Service Interruption

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 11:51 CST

Update

Northwestern IT will continue to monitor services until Cloudflare as announced the incident resolved.


The next update will be provided by 13:00 CST.
Posted Nov 18, 2025 - 11:03 CST

Update

Northwestern IT will continue to monitor services until Cloudflare as announced the incident resolved.


The next update will be provided by 11:00 CST.
Posted Nov 18, 2025 - 10:05 CST

Monitoring

We are beginning to see services restore for Online Giving and other Cloudflare dependent services.

Cloudflare has implemented a fix but has not yet declared the incident resolved.

Northwestern IT will continue to monitor services until Cloudflare as announced the incident resolved.

The next update will be provided by 10:00 CST.
Posted Nov 18, 2025 - 08:48 CST

Identified

Northwestern Information Technology has identified an issue causing a service interruption to Northwestern Online Giving. While the vendor is working to resolve this issue as quickly as possible, we have not yet received a project resolution time.

The vendor is posting updates via https://www.cloudflarestatus.com/incidents/8gmgl950y3h7

The next update will be provided by 9:30 CST.
Posted Nov 18, 2025 - 08:32 CST
This incident affected: Administrative and Business (Our Northwestern (Alumni and Advancement), CatConnect (Alumni and Advancement)).