Smartsheet Service Interruption

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 14:03 CDT

Update

The vendor is still closely monitoring Smartsheet to ensure the stability of the service.

Updates from the vendor are accessible at: https://status.smartsheet.com/incidents/5mg28zsf575c

The next will be provided by 14:00 CDT.
Posted Aug 26, 2026 - 12:56 CDT

Monitoring

The vendor has implemented a fix to mitigate the issue causing Smartsheet to be unavailable. Northwestern Information Technology and the vendor are closely monitoring to ensure the stability of the service.

Updates from the vendor are accessible at: https://status.smartsheet.com/incidents/5mg28zsf575c

The next will be provided by 13:00 CDT.
Posted Aug 26, 2026 - 11:51 CDT

Update

Northwestern Information Technology has identified an issue and Smartsheet is unavailable.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

Updates from the vendor are accessible at: https://status.smartsheet.com/incidents/5mg28zsf575c

The next update will be provided by 12:00 CDT.
Posted Aug 26, 2026 - 10:25 CDT

Identified

Northwestern Information Technology has identified an issue and Smartsheet is unavailable.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 11:00 CDT.
Posted Aug 26, 2026 - 10:05 CDT
This incident affected: Administrative and Business (Smartsheet).