Team Dynamix Service Interruption

Resolved

This incident has been resolved.
Posted May 18, 2026 - 12:22 CDT

Monitoring

The vendor has implemented a fix, and services are restored at this time.

Support teams and vendor will monitor services for a period to ensure this issue is resolved.

The next update will be provided by 12:30 CDT
Posted May 18, 2026 - 11:25 CDT

Identified

Northwestern Information Technology has identified an issue with Team Dynamix impacting a subset of services.

IT support staff are working with vendor to restore full service as quickly as possible.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by 11:30 CDT
Posted May 18, 2026 - 10:36 CDT
This incident affected: Professional Services (Service Management Platform (Service Delivery and Support)).