CAESAR - Several web services have been impacted after DB maintenance this morning
Resolved
The CAESAR incident has been resolved, and everything is working as expected.
Posted Jan 11, 2025 - 18:54 CST
Update
We are continuing to investigate this incident in order to get it resolved as quickly as possible

Next update will be at 19:00 CST
Posted Jan 11, 2025 - 18:00 CST
Investigating
We are currently investigating an incident with CAESAR. Several web services have been impacted after database maintenance this morning.

Next update will be at 18:00 CDT
Posted Jan 11, 2025 - 17:07 CST
This incident affected: Administrative and Business (CAESAR (Student Information Systems)).