The next update will be made by 16:00 CDT on Tuesday, April 28th.
Posted Apr 27, 2026 - 15:55 CDT
Update
Vendor support staff are currently working to restore proper configuration settings to all devices. Device based print release is currently unreliable.
The next update will be made by 16:00 CDT on Monday, April 27th.
Posted Apr 25, 2026 - 21:12 CDT
Update
Vendor support staff are currently working to restore proper configuration settings to all devices. Device based print release is currently unreliable.
The next update will be made by 16:00 CDT on Saturday, April 25th.
Posted Apr 24, 2026 - 15:56 CDT
Identified
Northwestern Information Technology has identified an issue and Northwestern Print is unavailable.
While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.
The next update will be provided by 16:00 CDT on Saturday, April 25th.
Posted Apr 24, 2026 - 15:07 CDT
Investigating
Northwestern Information Technology has identified an issue affecting the PaperCut service’s ability to load correctly following an SSL certificate update. As a result, most Northwestern printing functions are currently unavailable.
The next update will be provided by 16:00 CDT
Posted Apr 24, 2026 - 08:46 CDT
This incident affected: Software and Applications (Northwestern Print).