Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 19:00 CDT
Update
Minor updates made to impacted services in.
Posted Mar 17, 2025 - 15:28 CDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 17, 2025 - 15:26 CDT
Scheduled
Northwestern Information Technology will be upgrading software on Data Center load balancers. This work is being performed to bring data center load balancers software up to a current release of software and mitigate several security vulnerabilities. No interruption will be expected due to the redundancy of the system.
This maintenance includes the services below. AD Federation AD LDAP CAESAR Directory Exchange/Email/ Microsoft Collaboration Services myHR: Careers myHR myHR: Reports myPhone myVoicemail NU Financial InfoEd NUInfo/http://www.northwestern.edu NUValidate Registry Sharepoint Splunk Voicemail WebSSO
Posted Mar 17, 2025 - 14:47 CDT
This scheduled maintenance affected: Infrastructure (Load Balancing (Network Connectivity)).