Talkdesk Log-in Outage

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 13:40 CDT

Monitoring

The Northwestern IT call center has confirmed they are able to sign into TalkDesk, and the software vendor is monitoring for any further service interruptions.

The next update will be provided by 1400 PM, CDT.
Posted Jun 10, 2025 - 11:39 CDT

Investigating

Talkdesk has reported users in the US region being unable to log in, and Northwestern IT call center staff are unable to log in to receive calls. The software vendor is investigating and will provide updates on service restoration as they occur.

The next update will be provided by 1400 PM, CDT.
Posted Jun 10, 2025 - 10:34 CDT
This incident affected: Voice Services (Call Centers (Videoconferencing and Telephones)).