1819 Hinman - Power Interruption

Resolved

This incident has been resolved.
Posted May 22, 2026 - 14:48 CDT

Identified

Northwestern Information Technology has monitored an interruption of utility power at 1819 Hinman. Affected services include network connectivity including VoIP phone, wireless, and wired services,

Next update will be posted by 16:00 CDT
Posted May 22, 2026 - 11:19 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).