Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 12, 2025 - 06:00 CDT
Scheduled
Northwestern Information Technology will be performing maintenance on network security equipment which filters traffic between the internet and campus. This work is being performed to upgrade software to the latest vendor recommended release. There will be 2 brief interruptions in service when equipment is failed over. In addition, remote sites will be impacted as follows:
Below are the remote sites that will be affected for 30-60 minutes during the posted window: - C-squared for monitoring/reporting - Facilities Connect - Parlance - Redcap/StudyTracker access through Apporto Health App - NUworkspace/Apporto
Below are the remote sites with redundancy that may see a few minutes of downtime: - Medill School of Journalism at 44 MONTGOMERY, SAN FRANCISCO, CA - Government Relations Office at Washington DC - NYC alumni office - Azure cloud services - Amazon Web Services - Google Clous Service - Qatar Campus - Ricoh Print Services
Posted Oct 06, 2025 - 16:40 CDT
This scheduled maintenance affected: Infrastructure (Internet Network Services (Network Connectivity)).