Northwestern Information Technology confirms the incident is resolved for 1Password.
Posted Apr 28, 2026 - 14:11 CDT
Update
Northwestern Information Technology and the vendor have continued to see normal performance for the application. We will continue monitoring until the vendor announces the incident is resolved. The next update will by made by 15:00 CDT.
Posted Apr 28, 2026 - 09:38 CDT
Update
Northwestern Information Technology is seeing improvement in service delivery for 1Password and will continue to monitor until the issue is resolved and service is fully restored.
The next update will be provided by 09:00 CDT on Tuesday, April 28th.
Posted Apr 27, 2026 - 16:55 CDT
Update
Northwestern Information Technology is seeing improvement in service delivery for 1Password and will continue to monitor until the issue is resolved and service is fully restored.
The next update will be provided by 17::00 CDT.
Posted Apr 27, 2026 - 15:10 CDT
Monitoring
Northwestern Information Technology is seeing improvement in service delivery for 1Password and will continue to monitor until the issue is resolved and service is fully restored.
The next update will be provided by 15::00 CDT.
Posted Apr 27, 2026 - 13:02 CDT
Identified
Northwestern Information Technology has identified a vendor issue with 1Password. The vendor is working on a resolution. The next status update will be made by 13:00 CDT.
Posted Apr 27, 2026 - 10:39 CDT
This incident affected: Identity and Access Management (1Password (Password Management)).