Vendor has resolved the issue that was causing degraded performance in TeamDynamix Work Management, and full service has now been restored.
This incident has been resolved.
Posted Nov 10, 2025 - 15:39 CST
Update
The vendor continues work to restore service.
The next update will be provided by 16:30 CST.
Posted Nov 10, 2025 - 15:22 CST
Update
The vendor continues work to restore service.
The next update will be provided by 15:30 CST.
Posted Nov 10, 2025 - 14:25 CST
Update
The vendor continues work to restore service.
The next update will be provided by 14:30 CST.
Posted Nov 10, 2025 - 13:27 CST
Identified
Our vendor, TeamDynamix reports the fix did not produce the expected improvements, and we are still seeing performance challenges. They are continuing to work on service restoration.
The next update will be provided by 13:30 CST.
Posted Nov 10, 2025 - 12:26 CST
Monitoring
Northwestern IT has observed services return to normal operation, and we are awaiting confirmation from the vendor that services are fully restored.
We will continue to monitor services and update once vendor has issued a service restoration confirmation.
The next update will be provided by 12:30 CST.
Posted Nov 10, 2025 - 11:10 CST
Identified
Northwestern IT has identified an issue affecting the IT Service Management Portal and a subset of services, including the TDNext agent environment. End users can still reach the portal homepage, view and submit tickets, and access Knowledge Base articles.
We are working with TeamDynamix to resolve the issue as soon as possible. You may view updates on the vendor's status page here:
The vendor continues to investigate this issue. While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.
The next update will be provided by 11:00 CST.
Posted Nov 10, 2025 - 10:05 CST
Investigating
Northwestern Information Technology has identified an issue with Service Management Platform impacting a subset of services.
While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.