Qualtrics Service Interruption.

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 16:50 CDT

Update

Support staff are continuing to work with the vendor to restore service.

The next update will be provided by Friday, October 17, 2025 at 10:00 CDT
Posted Oct 16, 2025 - 16:00 CDT

Update

Support staff are continuing to work with the vendor to restore service.

The next update will be provided by 16:00 CDT
Posted Oct 16, 2025 - 14:04 CDT

Update

Support staff are continuing to work with the vendor to restore service.

The next update will be provided by 14:00 CDT
Posted Oct 16, 2025 - 11:44 CDT

Update

Support staff are continuing to work with the vendor to restore service.

The next update will be provided by 12:00 CDT
Posted Oct 16, 2025 - 10:08 CDT

Identified

Northwestern Information Technology has identified an issue with Qualtrics.

Support staff are continuing to work with the vendor to restore service.

The next update will be provided by 10:00 CDT
Posted Oct 15, 2025 - 17:21 CDT

Investigating

Northwestern Qualtrics is experiencing an issue with our SMTP integration that is preventing some users from being able to send out Surveys.

Support staff are working with the vendor to restore service.

The next update will be provided by 18:00 CDT.
Posted Oct 15, 2025 - 16:03 CDT
This incident affected: Software and Applications (Qualtrics (Research Tools)).