This incident has been resolved and service has been restored.
Posted Nov 09, 2025 - 06:01 CST
Update
The Internet Service Provider continues to investigate this issue and is working on restoring service as soon as possible.
The next update will be provided by Sunday, November 9th at 09:00 CST.
Posted Nov 08, 2025 - 20:00 CST
Update
The Internet Service Provider continues to investigate this issue and is working on restoring service as soon as possible.
The next update will be provided by 20:00 CST.
Posted Nov 08, 2025 - 15:27 CST
Update
The Internet Service Provider continues to investigate this issue and is working on restoring service as soon as possible.
The next update will be provided by 15:00 CST.
Posted Nov 08, 2025 - 13:02 CST
Investigating
Northwestern Information Technology has monitored the loss of one network connection to an Internet Service Provider. There is no impact to the service due to redundant connectivity. The Internet Service Provider has been engaged and is working on restoring service as soon as possible.
The next update will be provided by 13:00 CST.
Posted Nov 08, 2025 - 11:01 CST
This incident affected: Infrastructure (Internet Network Services (Network Connectivity)).