myHR Self Service - Service Degradation

Resolved

This incident has been resolved.
Posted May 20, 2026 - 13:51 CDT

Update

Northwestern Information Technology is continuing to investigate the myHR Self Service degraded performance. The next update will be made by 14:00 CDT.
Posted May 20, 2026 - 11:59 CDT

Investigating

Northwestern Information Technology is investigating an issue causing longer than normal response times for myHR Self Service.

The next update will be provided by 12:00 CDT.
Posted May 20, 2026 - 10:19 CDT
This incident affected: Administrative and Business (myHR (Human Resources Systems)).