The scheduled maintenance has now been extended until 12:00 CDT.
Posted Oct 30, 2025 - 10:49 CDT
Update
The scheduled maintenance has now been extended until 11:00 CDT.
Posted Oct 30, 2025 - 09:51 CDT
Update
The scheduled maintenance has now been extended until 10:00 CDT.
Posted Oct 30, 2025 - 08:53 CDT
Update
The scheduled maintenance has been extended until 9:00 CDT.
Posted Oct 30, 2025 - 07:56 CDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 30, 2025 - 07:00 CDT
Scheduled
Northwestern IT will be working with our vendor to perform certificate patching on the two-way radio system this Thursday October 30, 2025. During this maintenance window no service interruption is expected. Departmental radio dispatch and general two-way radio coverage and operation on the Evanston and Chicago campuses will not be impacted.
Posted Oct 27, 2025 - 10:20 CDT
This scheduled maintenance affected: Voice Services (Two-Way Radios (Videoconferencing and Telephones)).