1922, 1936, and 1940 Sheridan. 600 Foster | Network Equipment - FM Related Power Work

Resolved

This incident has been resolved.
Posted Sep 16, 2025 - 08:37 CDT

Update

Northwestern Facilities and Commonwealth Edison continue working to restore power to the affected locations.

The next update will be provided by Sep 16, 2025 - 09:00 CDT
Posted Sep 15, 2025 - 13:45 CDT

Identified

Northwestern Information Technology has been informed by Facilities Management of emergency power work at the locations in the title. Network connectivity including VoIP phone, wireless, and wired services will be affected while emergency work is completed.


The next update will be provided by 14:00 CDT
Posted Sep 15, 2025 - 10:43 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).