Northwestern Web Domain Accessibility Degradation

Update

Northwestern Information Technology has monitored significantly improved performance for enterprise applications and web sites this evening as a result of the remediation measures that have been put in place. This incident will remain in the monitoring state throughout the weekend, and personnel will be available for immediate response in the event of any reported or observed issues that occur.

The next update will be made by 15:00 CDT on Monday, May 11th.
Posted May 09, 2026 - 22:24 CDT

Update

Northwestern IT has continued to work with our vendor today to implement additional remediation measures to prevent performance issues from affecting enterprise applications and web sites. Personnel will be closely monitoring the effectiveness of these steps this evening.

The next update will be posted by 22:00CDT on Saturday, May 9.
Posted May 09, 2026 - 16:10 CDT

Update

Northwestern Information Technology continues to monitor performance issues with enterprise applications and some web sites. While there has been some improvement, there are still occasional periods of degraded performance. We have implemented additional remediation steps and are also escalating our support requests with the vendor for the affected infrastructure.

The next update will be made by 17:00 CDT on Saturday, May 9th.
Posted May 08, 2026 - 22:47 CDT

Update

Northwestern University Information Technology is closely monitoring the performance of enterprise applications and affected websites after the deployment of remediation measures last night.

Another round of system testing is scheduled for 20:00 PM CDT tonight to observe the remediation and ensure service up-time is not affected.

The next update will be provided by 22:00 PM CDT.
Posted May 08, 2026 - 14:52 CDT

Monitoring

Northwestern Information Technology has completed the deployment of short term remediation measures to alleviate performance issues for enterprise applications and some web sites. We will continue to monitor systems and infrastructure closely to ensure that those measures remain effective throughout the day tomorrow and make any necessary adjustments.

The next update will be provided by 15:00 CDT on Friday, May 8th.
Posted May 07, 2026 - 22:57 CDT

Identified

During tonight's analysis session, Northwestern Information Technology identified a root cause for the performance issues that were affecting enterprise applications and web sites, and is working to implement short term measures to alleviate the impact on the infrastructure.

The next update will be made by 23:30 CDT.
Posted May 07, 2026 - 22:03 CDT

Update

Performance of enterprise applications and web sites has been normal throughout the day. Northwestern IT continues to investigate the root cause of the incident.

A recurrence of slow performance is expected this evening starting around 20:00 CDT. Northwestern IT personnel will be actively monitoring systems and infrastructure during this time to capture live data and apply any remediations.

The next update will be provided by 22:00 CDT.
Posted May 07, 2026 - 16:00 CDT

Update

Performance for enterprise applications and web sites has returned to normal as of early Thursday morning.  Northwestern IT continues to investigate the root causes for the performance degradation and any corrective actions that may be needed.  

The next update will be provided by 16:00 CDT on Thursday, May 7.
Posted May 07, 2026 - 10:08 CDT

Update

Northwestern Information Technology continues to investigate and troubleshoot the issue with slow performance and failure to load certain university web domains both on-campus and off-campus.

The next update will be provided by 8:00 CDT on Thursday.
Posted May 06, 2026 - 23:08 CDT

Investigating

Northwestern University Information Technology identified that several university web domains are loading slowly or failing to load for both on-campus and off-campus users. Network engineers are currently troubleshooting the issue.

The next update will be provided by 23:00 CDT.
Posted May 06, 2026 - 21:55 CDT
This incident affects: Administrative and Business (CAESAR (Student Information Systems), myHR (Human Resources Systems), NUFinancials (Finance and Procurement Systems)) and Infrastructure (Load Balancing (Network Connectivity)).