Webmail access is experiencing issues

Resolved

This incident has been resolved.
Posted Mar 01, 2025 - 16:53 CST

Update

We are continuing to investigate this issue.
Posted Mar 01, 2025 - 15:35 CST

Investigating

Webmail access is experiencing errors, and we are looking into this issue.

Next update is at 4:30 CST
Posted Mar 01, 2025 - 15:33 CST
This incident affected: Communication and Collaboration (Office 365 (Email and Calendaring)).