Call Center Talkdesk Service Interruption

Resolved

This incident has been resolved
Posted Mar 31, 2025 - 16:39 CDT

Update

Support staff continue monitoring service restoration at this time.

The next update will be provided by 17:00 CDT.
Posted Mar 31, 2025 - 15:58 CDT

Update

Support staff continue monitoring service restoration at this time.

The next update will be provided by 16:00 CDT.
Posted Mar 31, 2025 - 14:59 CDT

Update

Support staff continue monitoring service restoration at this time.

The next update will be provided by 15:00 CDT.
Posted Mar 31, 2025 - 13:55 CDT

Update

We are continuing to monitor for any further issues.
Posted Mar 31, 2025 - 13:01 CDT

Monitoring

The vendor has implemented a fix and services are restoring. Support staff will continue to monitor until services are fully restored.

The next update will be provided by 14:00 CDT.
Posted Mar 31, 2025 - 13:01 CDT

Identified

Northwestern Information Technology has identified an issue with Talkdesk Call Center service impacting incoming calls for a subset of services.

Support staff are working with vendor to restore services.

The next update will be provided by 13:00 CDT.
Posted Mar 31, 2025 - 11:14 CDT
This incident affected: Voice Services (Call Centers (Videoconferencing and Telephones)).