CERES (Research Administration Systems) Service Interruption
Resolved
Service has been restored by the vendor.
Posted Sep 18, 2023 - 09:32 CDT
Identified
Northwestern Information Technology has identified an issue with CERES (Research Administration Systems) impacting a subset of services. While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time.

The next update will be provided by Monday, September 18 at 09:00 CDT.
Posted Sep 17, 2023 - 07:32 CDT
This incident affected: Administrative and Business (CERES (Research Administration Systems)).