Northwestern Information Technology has dispatched a technician to resolve the issue and restore telephone, wired, and wireless network services.
The next update will be provided on Monday by 9:00 CDT.
Posted Mar 07, 2026 - 14:03 CST
Update
Northwestern Information Technology is still investigating and working to resolve this issue as quickly as possible, but we have not yet received a projected resolution time.
The next update will be provided by 08:30 CST.
Posted Mar 07, 2026 - 04:30 CST
Investigating
Northwestern Information Technology has identified an issue with power impacting a subset of services at the posted location.
Facilities Management is working to restore full service as quickly as possible.
The next update will be provided by 04:30 CST.
Posted Mar 07, 2026 - 03:29 CST
This incident affects: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).