CATracks Service Interruption
Resolved
Northwestern Information Technology confirms the incident is resolved for CATracks.

Clearing browser caches, deleting cookies and restarting have resolved the issues for affected users.
Posted Apr 22, 2024 - 11:28 CDT
Identified
Northwestern Information Technology has identified an issue with CATracks impacting a subset of services.

IT support staff are working to restore full service as quickly as possible.

The next update will be provided by 13:00 CDT.
Posted Apr 22, 2024 - 10:57 CDT
This incident affected: Administrative and Business (CATracks (Alumni and Advancement)).