South Evanston Campus Power Interruption

Resolved

Northwestern Information Technology confirms that the incident has been resolved.

Service was restored at 13:49 CDT.
Posted Mar 30, 2025 - 16:01 CDT

Monitoring

Northwestern Information Technology confirms power has been restored and that wired, wireless, and telephone services in the affected buildings are recovering. We will continue to monitor as services recover and stabilize.

The next update will be provided by 16:00 CDT.
Posted Mar 30, 2025 - 14:16 CDT

Update

The electric utility company continues to work on restoring power.

The next update will be provided by 15:00 CDT.
Posted Mar 30, 2025 - 13:06 CDT

Identified

Northwestern Information Technology has identified a power outage affecting the south Evanston campus. The electric utility company has been engaged to restore power. There is no estimated restoration time available yet.

The next update will be provided by 13:00 CDT.

The following buildings are currently affected by this power outage:

600 FOSTER
633 EMERSON
FOSTER-WALKER
HOBART HOUSE
1902 SHERIDAN
1908 SHERIDAN
1914 SHERIDAN
1918 SHERIDAN
1936 SHERIDAN
1940 SHERIDAN
Posted Mar 30, 2025 - 11:59 CDT
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).