Northwestern Loan Application System Service Interruption

Resolved

Northwestern Information Technology confirms the incident is resolved for Northwestern Loan Application System.
Posted Nov 07, 2025 - 14:42 CST

Identified

Northwestern Information Technology has identified an issue and Northwestern Loan Application System is unavailable.

IT support staff are working to restore full service as quickly as possible.

The next update will be provided by 15:30 CST.
Posted Nov 07, 2025 - 13:59 CST
This incident affected: Administrative and Business (Northwestern Loan Application System (Student Information Systems)).