iBuyNU (Finance and Procurement Systems) Service Interruption

Resolved

Service has been restored to iBuyNU. The vendor has confirmed that the underlying service disruption has been resolved.
Posted Aug 19, 2026 - 21:24 CDT

Update

Northwestern Information Technology has identified restoration for iBuyNU, but we are awaiting a confirmation from the vendor.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time or confirmation of restored services.

The next update will be provided by Thursday, August 20th at 10:00 CDT.
Posted Aug 19, 2026 - 16:38 CDT

Update

Northwestern Information Technology has identified restoration for iBuyNU, but we are awaiting a confirmation from the vendor.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time or confirmation of restored services.

The next update will be provided by 17:00 CDT.
Posted Aug 19, 2026 - 15:10 CDT

Update

Northwestern Information Technology has identified restoration for iBuyNU, but we are awaiting a confirmation from the vendor.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time or confirmation of restored services.

The next update will be provided by 15:30 CDT.
Posted Aug 19, 2026 - 14:09 CDT

Update

Northwestern Information Technology has identified restoration for iBuyNU, but we are awaiting a confirmation from the vendor.

While the vendor is working to resolve this issue as quickly as possible, we have not yet received a projected resolution time or confirmation of restored services.

The next update will be provided by 14:30 CDT.
Posted Aug 19, 2026 - 13:08 CDT

Identified

The vendor has identified a performance issue that is causing a service interruption to iBuyNU (Finance and Procurement Systems). There is no estimated time available yet for when the service interruption will be resolved. Support staff are working toward a full resolution as soon as possible.

The next update will be provided by 14:00 CDT.
Posted Aug 19, 2026 - 12:41 CDT
This incident affected: Administrative and Business (iBuyNU (Finance and Procurement Systems)).