(57713) Two-Way Radio System Equipment Maintenance - Chicago

Scheduled for Apr 14, 06:00 - 08:00 CDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 09, 2026 - 15:56 CDT

Scheduled

Northwestern IT and Northwestern Facilities will be working with our vendor to relocate a mechanical switch that provides power to the Chicago two-way radio system on Tuesday April 14, 6am-8am. During this maintenance window no service interruption is expected. Departmental radio dispatch and general two-way radio coverage and operation on the Evanston and Chicago campuses will not be impacted.
Posted Apr 09, 2026 - 13:25 CDT
This scheduled maintenance affects: Voice Services (Two-Way Radios (Videoconferencing and Telephones)).