Northwestern Information Technology confirms the incident is resolved for Two-Way Radios. Service was fully restored at 20:22 CDT.
Posted Oct 24, 2025 - 20:51 CDT
Monitoring
Northwestern Information Technology confirms service has been restored for Two-Way Radios as of 20:22 CDT and will continue to monitor the restoration.
The next update will be provided by 22:00 CDT.
Posted Oct 24, 2025 - 20:41 CDT
Identified
Northwestern Information Technology has identified an issue causing a service interruption for Two-Way Radios and is currently working towards resolution.
The next update will be provided by 21:00 CDT.
Posted Oct 24, 2025 - 19:58 CDT
Update
Northwestern Information Technology is investigating a service interruption for Two-Way Radios.
The next update will be provided by 20:00 CDT.
Posted Oct 24, 2025 - 18:20 CDT
Investigating
Northwestern Information Technology is investigating a Radio Communications interruption
The next update will be provided by 18:30 CDT
Posted Oct 24, 2025 - 17:20 CDT
This incident affected: Voice Services (Two-Way Radios (Videoconferencing and Telephones)).