Northwestern New York - Network Service Interruption

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 17:03 CDT

Monitoring

The vendor has resolved an issue with their network equipment and Northwestern Information Technology has monitored a recovery of internet network services at the New York office for Alumni Relations and Development.

The next update will be provided by 16:00 CDT.
Posted Jul 21, 2026 - 15:05 CDT

Identified

The vendor has identified an issue with their network equipment and dispatched a field engineer. An estimated time for restoration of internet network services has not yet been provided at this time.

The next update will be provided by 16:00 CDT.
Posted Jul 21, 2026 - 13:58 CDT

Update

The vendor is still investigating and working to restore service as soon as possible.

The next update will update will be provided by 14:00 CDT.
Posted Jul 21, 2026 - 12:23 CDT

Investigating

Northwestern Information Technology is investigating an issue causing a service interruption to internet network service at the New York office for Alumni Relations and Development. The vendor has been engaged to restore service as soon as possible.

The next update will be provided by 12:30 CDT.
Posted Jul 21, 2026 - 11:23 CDT
This incident affected: Infrastructure (Internet Network Services (Network Connectivity)).