Medill School of Journalism at 44 MONTGOMERY, SAN FRANCISCO, CA - Service Interruption

Resolved

This incident has been resolved.
Posted Nov 21, 2025 - 08:52 CST

Identified

Northwestern Information Technology has reached out to the Internet Service Provider and they are working to resolve this issue as quickly as possible. A technician may be sent to the site first thing in the morning.

The next update will be provided by Friday, November 21st at 09:00 CST.
Posted Nov 20, 2025 - 21:30 CST

Investigating

Northwestern Information Technology has identified an issue with network connectivity impacting services at the posted location.

Support staff are working to restore full service as quickly as possible.

The next update will be provided by 21:30 CDT/CST.
Posted Nov 20, 2025 - 20:46 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).