Technological Institute 2nd floor J wing Network Service Interruption
Resolved
This incident has been resolved. Services are restored.
Posted Jul 24, 2024 - 14:17 CDT
Investigating
Northwestern Information Technology has identified an issue with wired, wireless, and telephone services on the 2nd floor J wing of Technological Institute. Information Technology support staff are working to restore service as quickly as possible.

The next update will be provided by 16:00 CDT.
Posted Jul 24, 2024 - 14:06 CDT
This incident affected: Voice Services (Two-Way Radios (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).