Microsoft AZURE Service Interruption

Resolved

Northwestern Information Technology confirms the incident is resolved for Microsoft AZURE.
Posted Jan 12, 2026 - 18:15 CST

Monitoring

Northwestern Information Technology is seeing improvement in service delivery for Microsoft AZURE. Service may still be degraded and redundancy is still reduced. We will continue to monitor until the issue is resolved and service is fully restored.

The next update will be provided by 19:00 CST.
Posted Jan 12, 2026 - 17:33 CST

Identified

Northwestern Information Technology has identified an issue with Microsoft AZURE impacting a subset of services.

IT support staff are working to restore full service as quickly as possible.

The next update will be provided by 18:00 CST.
Posted Jan 12, 2026 - 16:57 CST
This incident affected: Infrastructure (Microsoft AZURE (Cloud Service)).