North Evanston Campus Power Interruption

Resolved

Northwestern Information Technology and NUPD have verified that all services have been restored as of 21:00 CST. We are closing this posting.
Posted Mar 04, 2025 - 21:23 CST

Monitoring

Northwestern Information Technology has confirmed that services are coming back online. We will continue to monitor system performance and a final posting will be made by 22:00 CST.
Posted Mar 04, 2025 - 19:47 CST

Update

Northwestern Information Technology has identified that the effected buildings are Tech and Francis Searle. Facilities Management is continuing to work on the outage.

2240 CAMPUS DR Frances Searle Building
2145 SHERIDAN RD Technological Institute

The next posting will be made by 22:00 CST.
Posted Mar 04, 2025 - 19:13 CST

Update

We are continuing to work on a fix for this issue.
Posted Mar 04, 2025 - 19:05 CST

Identified

Northwestern Information Technology and NUPD have identified a power outage effecting the north side of the Evanston campus. Facilities Management has been engaged to troubleshoot the problem. An update will be posted by 22:00 CST.
Posted Mar 04, 2025 - 18:52 CST
This incident affected: Voice Services (Telephone Services (Videoconferencing and Telephones)) and Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).