Chicago Network Service Interruption

Resolved

Northwestern Information Technology has confirmed that the network has been restored and is operating normally. We are closing this posting.
Posted Apr 07, 2026 - 08:53 CDT

Update

Northwester Information Technology is continuing to investigate this issue. The next update will be posted by 09:30 CDT.
Posted Apr 07, 2026 - 08:14 CDT

Investigating

Northwestern Information Technology is investigating an issue effecting a small number of devices on the Chicago network effecting 303 East Chicago Ave, Montgomery Ward Building after planned maintenance. The next status update will be made by 08:30 CDT
Posted Apr 07, 2026 - 07:06 CDT
This incident affected: Infrastructure (Wired Network Services (Network Connectivity), Wireless Network Services (Network Connectivity)).