CATracks Service Interruption
Resolved
Northwestern Information Technology confirms that the incident for CATracks (Alumni and Advancement) has been resolved and service has been restored.
Posted Apr 19, 2024 - 13:21 CDT
Update
Northwestern Information Technology is continuing to work on restoring service as quickly as possible for CATracks (Alumni and Advancement).

The next update will be provided by 13:30 CDT.
Posted Apr 19, 2024 - 12:58 CDT
Identified
Northwestern Information Technology has identified an issue and CATracks (Alumni and Advancement) is unavailable. Support staff are working to restore service as quickly as possible.

The next update will be provided by 13:00 CDT.
Posted Apr 19, 2024 - 12:32 CDT
This incident affected: Administrative and Business (CATracks (Alumni and Advancement)).