NUFinancials October CPU Patch - Saturday, November 8

Scheduled for Nov 8, 07:00 - 15:00 CST

Update

Updating affected services.
Posted Nov 03, 2025 - 10:04 CST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 03, 2025 - 10:03 CST

Update

We will be undergoing scheduled maintenance during this time.
Posted Nov 03, 2025 - 10:02 CST

Scheduled

The NUFinancials system will undergo scheduled maintenance to apply a required platform and application update starting on Saturday, November 8, at 7 a.m. and ending at approximately 3 p.m. The maintenance necessitates system downtime, and NUFinancials will be unavailable during the maintenance window.
Posted Nov 03, 2025 - 09:26 CST
This scheduled maintenance affects: Administrative and Business (CAESAR (Student Information Systems), myHR (Human Resources Systems), NUFinancials (Finance and Procurement Systems)).